Introduccion

Introducción

Es bastante difícil escribir un texto sin que vayamos repitiendo palabras de manera inconsciente según avanzamos por él. La aplicación RepeText busca y encuentra palabras repetidas en el texto introducido. Es posible configurar la distancia máxima entre palabras para que sean consideradas repetidas y la longitud mínima de estas. Pueden buscarse repeticiones de palabras, de frases o grupos de palabras, o de palabras que empiecen o terminen igual. (Buscar repeticiones)

Además, existen pestañas desde la que podremos buscar rimas internas en el texto (Rimas), búsqueda avanzada de cadenas de texto (Búsqueda de texto) y ver algunas estadísticas taels como el número de palabras, de párrafos, de caracteres, párrafos más largos, etc.(Estadísticas)


caracteristicas

Características Generales

  • Importación de documentos de texto plano, Word, PDF y RTF (formatos de texto enriquecido)
  • Buscador de repeticiones en un texto
  • Opción de buscar repeticiones según distancia entre palabras
  • Opción de búsqueda de palabras que empiecen igual
  • Opción de búsqueda de palabras que terminen igual
  • Buscador de frases y secuencias de caracteres
  • Búsqueda de rimas internas
  • Búsqueda avanzada de texto (exacta, contiene, aproximada, varias palabras, expresiones regulares)
  • Estadisticas
  • Ayuda desde el programa


Requisitos

Windows Vista, 7, 8, 10 o superior.


menu

Barra de Menús

  • Archivo
    • Abrir
    • Salir
  • Edición
    • Copiar
    • Cortar
    • Pegar
    • Seleccionar todo
    • Borrar todo
  • Ayuda


Abrir

Menú: Archivo / Abrir

Desde este menú puede introducir en la aplicación un archivo de texto, un documento de Word, uno con formato RTF (Rich Text Format) o un PDF. Será en este texto donde RepeText hará las búsquedas. También puede utilizar el programa tecleando directamente o pegando algún texto previamente copiado.


Salir

Menú: Archivo / Salir
Atajo: Ctrl + S

Cierra y sale del programa.


Copiar Cortar Pegar

Copiar, cortar y pegar

Menú: Edición/Copiar (Cortar) (Pegar)

  • Copiar (Ctrl + C), Cortar (Ctrl + X) y Pegar (Ctrl + V): Estos comandos permiten efectuar operaciones de copia y pegado del texto seleccionado.


Seleccionar todo

Menú: Edición / Seleccionar todo
Atajo: Ctrl + E

Selecciona todo el texto.


Borrar todo

Menú: Edición / Borrar todo
Atajo: Ctrl + B

Elimina el texto del panel principal y los resultados del panel de repeticiones y de búsqueda.


Ayuda

Menú: Ayuda / Ayuda
Atajo: F1

Desde este menú se accede a este mismo documento de ayuda. Podrá navegar por los temas del contenido o buscar las páginas que contengan una determinada palabra.

Aunque generalmente es poco utilizada, la pestaña "Búsqueda" es muy útil para buscar cualquier palabra en todo el archivo de ayuda.


Acerca de

Menú: Ayuda / Acerca de
Atajo: Ctrl + S

Muestra el nombre del programa (RepeText), autor (Santi Oliver), versión y copyright.


Busqueda repeticiones

Búsqueda de repeticiones

Una vez introducido el texto en el panel principal y configuradas las diferentes opciones pulsamos el botón "Buscar" y el programa nos mostrará una lista con las palabras más repetidas al principio. Si pulsamos en una de las palabras de la lista, quedarán resaltadas en el texto de color amarillo y así podrán ser identificadas más fácilmente.

Es posible ordenar el listado alfabéticamente o por número de repeticiones ascendente o descendentemente pulsando en el título de la columna.

Las diferentes opciones son:

  • Distancia máxima entre ocurrencias: Es la distancia máxima entre dos palabras para que el programa considere que se han repetido. Si no está seleccionada, el programa no tomará en cuenta la distancia y mostrará todas las repeticiones en el texto independientemente de lo cerca que estén unas palabras de otras.

  • Longitud mínima de palabra: Longitud mínima que han de tener las palabras. De esta manera se pueden ignorar repeticiones de palabras muy comunes como "el", "la", "y", "un", "en", "que", etc.

  • Palabras exactas: Busca repeticiones exactas. Así, por ejemplo, las palabras "hombre" y "hombres" no las considerará como repeticiones.

  • Frases: Busca repeticiones de frases o grupos de palabras.

  • Igual comienzo : Busca palabras que comiencen igual el número de palabras que introduzcamos: Por ejemplo, si elegimos esta opción e introducimos el número 5, nos dirá que "sorpresa", sorprendido y sorprendente son repeticiones.

  • Igual terminación: Lo mismo que con comienzo, pero al final de la palabra. Puede ser útil para buscar patrones, como el uso de los adverbios terminados en "mente", de los diminutivos terminados en "ito" o "ita", de rimas internas, etc.


Rimas

Desde esta pestaña podremos buscar las rimas consonantes (no las asonantes) que estén a una distancia establecida en el apartado "Distancia máxima entre rimas"


Busqueda de texto

Búsqueda de texto

Es posible utilizar la aplicación como un buscador avanzado de texto.

El nombre de las diferentes opciones es explicativo, por lo que no se abundará en ello:

  • Coincidir mayúsculas y minúsculas: Si está punteada la casilla, buscando "rosa" encontrará "rosa", pero no "Rosa"

  • Ignorar acentos: Si hemos punteado la casilla, buscando "angel" encontrará tanto "angel" como "ángel".

  • Contiene: Si buscamos, por ejemplo, "elo" encontrará "abuelo", "pelota" y "reloj"

  • Palabra exacta: Si buscamos, por ejemplo, "helado" encontrará "helado", pero no "heladora"

  • Aproximada: Busca palabras aproximadas al texto introducido. Por ejemplo, singulares y plurales, masculinos y femeninos, etc.

  • Varias palabras: Busca a la vez diferentes palabras separadas por comas. Muy útil para encontrar de un solo vistazo palabras sinónimas o conjugaciones verbales, por ejemplo.

  • Regex: Es posible introducir expresiones regulares que son un modo de hacer búsquedas complejas. Por ejemplo, para encontrar todas las palabras en el texto que empiecen por "a" y terminen por "s" podríamos introducir la expresión regular: \ba\w*s\b Haga clic aquí, para un resumen básico del empleo de estas expresiones.


RegEx

Expresiones regulares

Las Expresiones Regulares permiten buscar cadenas de texto complejas, comprobar la validez de fechas, documentos de identidad o contraseñas, reemplazar texto, analizar algoritmos de programación y muchos más usos.

Su uso es poco intuitivo y se basa en utilizar ciertas reglas y símbolos en una cadena de caracteres que el motor de búsqueda utilizará para saber los criterios deseados.

Para buscar, por ejemplo, la secuencia "arto" en un texto escribiríamos lo más sencillo que se puede hacer en una expresión regular, que es introducir los mismos caracteres buscados. En este caso la expresión regular sería: arto y encontraría "parto", "harto", "Martorell", etc. En cambio, para buscar "arto" seguida o no de una "s" al final de una palabra (y que no nos salga, por ejemplo "Martorell", la expresión regular sería artos?\b Por ello, para casos más complicados, son necesarios unos símbolos. A continuación indicamos algunos de los más básicos.

Listado de símbolos

\b :Límite entre palabras
\w (minúscula): Cualquier carácter alfanumérico
\W (mayúscula): Cualquier carácter no alfanumérico
\d : Un dígito
? : Ninguna o una ocurrencia
+ : Una o más ocurrencias
* : Ninguna o más ocurrencias
[ ] : Un conjunto de caracteres
{ , } : Un intervalo de veces
( ) : Todo lo que se introduzca entre paréntesis se evaluará independientemente, algo parecido a los paréntesis matemáticos.
| (barra vertical, Alt + 124) : OR lógico (para que se cumpla al menos una de las dos dos expresiones)

Ejemplos

  • Buscar a la vez las palabras "cuadro", "óleo", "retrato", "pintura"
    Expresión regular: cuadro|óleo|retrato|pintura
  • Buscar en un texto todas las palabras de 4 a 6 letras que empiecen por s
    Expresión regular: \b\w{4,6}\b
    (encontrará, por ejemplo, "solera", "sola", "somos", "seda", etc)
  • Buscar palabras que contengan una "e" y después (inmediatamente o no) una "m" o una "s"
    Expresión regular: \be\w*(m,s)\w*\b
    (encontrará, por ejemplo, "bellas", "siempre", "estoy", "relamoo", etc
  • Buscar diminutivos (palabras terminadas en "ito", "ita", "ín", "ina", "illo", "illa")
    Expresión regular: rong class="style1">\b\w+i(to|ta|ón|na|llo|lla){1,1}\b
    (encontrará, por ejemplo, "chiquilla", "dedito", "chiquitina", miradita, "papelín", etc., aunque también encontrará palabras no diminutivas como "silla" y "fin")


Estadisticas

Estadísticas

Número total de caracteres, alfanuméricos, palabras, etc.

Además, en el caso de que no se haya importado en formato PDF, mostrará el número de párrafos y número medio de palabras por párrafo, el párrafo más largo y la secuencia más larga (se considera secuencia como un texto continuo sin signos de puntuación tales como puntos, puntos y coma, etc) Se dibuja un gráfico con el tamaño de los párrafos y secuencias según el texto va avanzando.