Introduccion

TORNEOS DE AJEDREZ

  • Características generales

  • Instalación

  • Ayudas

  • Formulario "Generar Torneo ..."

  • Hoja "CuadroResultados"

  • Hoja "Clasificacion"

  • Formulario "Rondas"

  • Formulario "ELO"

  • Formulario "Jugadores"

  • Exportar a HTML

  • Gráfico Elo

  • Impresión

  • Restablecer configuración de Excel

Santiago Oliver - santiago@oliware.com


Restablecer Excel

  Torneos Ajedrez
Restablecer Excel

La aplicación necesita hacer cambios importantes en el entorno de Excel (esconder las barras propias de Excel, deshabilitar numerosas funciones de Excel, como el arrastrar celdas, esconder la barra de fórmulas, etc) Una vez que se cierra vuelve a restablecer los valores anteriores del usuario. No obstante en muy raras ocasiones (por ejemplo, un corte de luz cuando la aplicación esté funcionando) es posible que cuando se salga de la aplicación ésta no retorne a la configuración anterior de Excel y no aparezcan las barras de menús, no se vean las fórmulas, etc) En este caso se podrá ir al menú "?..." y pulsar el botón "Restablecer Excel" con lo que se restablecerá Excel a los valores más usuales (mostrar barra de menús, barra estándard, barra formato, permitir arrastrar y colocar, ver fórmulas, ver barra de estado, mostrar números en gráficos...) Luego se cerrará Excel automáticamente para que los cambios tengan efecto


Caracteristicas Generales

Caracteristicas Generales

La aplicación "Torneos de Ajedrez" lleva el seguimiento de una liga de ajedrez todos-contra-todos a una sola vuelta o a doble vuelta. El número máximo de jugadores en el torneo es de 29.
En un cuadro de resultados se van introduciendo los resultados por jornada, obteniéndose la clasificación en tiempo real y los puntos conseguidos en diferentes criterios de desempate.
Es posible calcular los efectos (clasificación y cambio de Elo) causados por unos hipotéticos resultados en jornadas futuras.
También calcula el Elo obtenido al final del torneo cuando se haya introducido el inicial de cada jugador.
En las hojas CuadroResultados y Clasificación podremos variar la escala de la ventana con el zoom en la barra de menús para adecuarlo a las preferencias de cada uno. Para introducir un valor arbitrario, teclearlo en el cuadro de texto de color blanco y pulsar Enter.

Según el nivel de seguridad que tengas en Excel (Herramientas/macros/seguridad) es posible que pregunte si se habilitan o no las macros. Para que esta aplicación funcione debes habilitar las macros o decirle a Excel que confíe siempre en el certificado aunque se diga que el origen del certificado no es de confianza (pues Microsoft no lo conoce)

Instalación


Instalacion

Instalación

Esta aplicación necesita Excel 2000, XP o superiores para funcionar correctamente. Hay una versión para Excel 2000 y otra para Excel XP ó 2002

Para instalar la aplicación ejecutar o hacer doble clic en el archivo Instalar.exe . El programa de instalación de una manera automática copiará la plantilla NuevoTorneo.xlt y el archivo AyudaTorneos.chm en la carpeta C:\Archivos de programa\TorneosAjedrez y pondrá un acceso directo en Inicio/Programas. También copiará algunas dll y archivos necesarios. En caso de que ya estén instalados, le preguntará si desea conservar los ficheros anteriores lo que aconsejo se haga.

Haciendo doble clic en la plantilla "NuevoTorneo.xlt" o abriéndolo desde Inicio/Programas (deberá habilitar las macros si Excel le pregunta) se inicializará el formulario de introducción de datos y se generará un nuevo archivo Excel con el nombre introducido del torneo. Será este nuevo archivo, situado donde se desee, el que se utilice en jornadas posteriores para llevar el seguimiento de la liga y podrán existir tantos archivos como torneos haya. La plantilla "NuevoTorneo" sólo se usará para generar un nuevo campeonato y en caso de abrirla para intentar modificarla aparecerá la petición de una contraseña.

Para desinstalarlo haz como con cualquier otro programa Windows: Inicio/Configuración/Añadir o quitar programas. También puedes desinstalarlo manualmente simplemente eliminando los archivos indicados más arriba, aunque te aconsejo el primer método.


Elo

Ayuda

Para acudir a esta ayuda desde las hojas CuadroResultados, Clasificación y Gráfico Elo, pulsar en la barra de menús el botón "?..." y el submenú "Ayuda". También puede pulsar el icono [image] de la ayuda en cualquier formulario en que se encuentre (Generar Torneo, Jugadores, Rondas y Elo) o pulsar F1 para recibir ayuda sobre la pantalla en cuestión.

(Con el fin de no alterar demasiado la configuración del sistema y no agrandar el tamaño del archivo de instalación no he incluido en la instalación los archivos necesarios para el visor de ayuda HTML. En caso de no tener Internet Explorer o no poder visualizar la ayuda puedes conseguir fácilmente los archivos necesarios en Internet o poniéndote en contacto conmigo)


Generar Torneo

Generar Torneo

Este formulario aparecerá la primera vez que se abra la aplicación. Es importante introducir bien los datos en este formulario inicial pues no volverá a aparecer. En caso de que se haya cometido un fallo después de generarse el torneo, no quedará más remedio que eliminar el archivo Excel creado y volver a empezar de nuevo. No obstante, hasta que no se pulse Aceptar se podrá corregir cualquier dato.

Nombre del Torneo: Introducir cualquier nombre de torneo, por ejemplo: Linares-1999

Jugador: Es importante que el nombre del jugador no sea demasiado largo, pues éste figurará en el cuadro de resultados y ensanchará su columna correspondiente, con lo que posiblemente el cuadro no se podrá ver entero y habrá que utilizar las barras de desplazamiento. No introducir un número como nombre, pues la aplicación generaría distintos errores.

Elo: La aplicación calcula la variación de Elo al finalizar el torneo. Para ello habrá que introducir el Elo inicial de cada jugador. En caso de no hacerlo, el programa supondrá un Elo mínimo inicial de 1800. El Elo inicial ha de estar comprendido entre 1800 y 3000. Pulsando Enter en este campo se añadirá el jugador a la lista de jugadores.

Botón Agregar: Con este botón se agrega el jugador introducido a la lista de abajo. El mismo resultado (y más rápido) se conseguirá pulsando Enter después de introducir el nombre del jugador y su Elo.

Botón Eliminar: Elimina el jugador seleccionado de la lista de jugadores.

Sistemas de desempate: A la hora de calcular la clasificación del torneo hay cuatro sistemas de desempate disponibles, Sonnenborg-Berger, Número de victorias, Resultados con negras y Resultado particular entre los empatados. Con las flechas a la derecha de la lista Sistemas de Desempate podremos indicar al programa qué prioridad debe aplicar a la hora de decidir el desempate. La flecha hacia arriba subirá la prioridad del sistema seleccionado y la flecha hacia abajo hará lo contrario.

Número de vueltas: Elegir la opción que corresponda al torneo.

Botón Aceptar: Cierra el formulario y genera el torneo. Ver las consideraciones del principio de la hoja.

Botón Cancelar: Cierra el formulario sin hacer nada.


Cuadro de Resultados

Cuadro de Resultados

Esta es la hoja en la que se introducirán los resultados.

Para cada partida introduce el número de jornada y el resultado (1 si ganan blancas, x (equis) ó 0,5 si tablas, 0 si ganan negras y -1 si pierden ambos contendientes por incomparecencia u otra razón)
Los datos se introducen en la intersección entre los contendientes (jugador con blancas en el extremo izquierdo y con negras en el extremo superior. Por ejemplo, en el gráfico Pedrosian ha ganado con blancas a Oliver)

La aplicación no permitirá introducir datos contradictorios, tal como que un jugador juegue dos veces en la misma ronda, introducir una jornada mayor de las que hay, etc.
En caso de que el torneo sea a una sola vuelta y se introduzca un resultado, por ejemplo Pedrosian-Oliver, automáticamente se colorearán las celdas correspondientes al resultado recíproco (Oliver-Pedrosian) indicando con ello que dichas celdas están bloqueadas y son de sólo lectura. Sólo se desbloquearán al borrar los datos de la celda recíproca.
En cualquier momento se podrán modificar los datos ya introducidos o borrar los existentes (con las teclas Supr o Del). Incluso se podrán calcular los efectos (clasificación y cambio de Elo) causados por unos hipotéticos resultados en jornadas futuras, simplemente introduciéndolos para posteriormente borrarlos.


Clasificacion

Clasificación

En esta hoja podemos ver a los jugadores ordenados por su puesto en la clasificación, tomando en cuenta los puntos conseguidos, las partidas jugadas y los diferentes criterios de desempate. No es necesario que haya concluido el torneo para ver los resultados en la clasificación. Incluso se pueden introducir resultados ficticios para ver cómo afectarían a la clasificación. ¿Qué pasaría si en la próxima ronda perdiese Kasparín y ganase Escaldao?¿Quién tendría mayor Sonnenborg-Berger? El orden de desempate vendrá dado por lo que se haya introducido al generar el torneo.
Esta hoja no es modificable puesto que está directamente vinculada al cuadro de resultados, que es donde se podrán editar los datos.


HTML

HTML

Haciendo clic en el botón HTML desde las hojas Clasificación o CuadroResultados se exportará el libro a formato web (HTML) con lo que podrá publicarse en Internet. Aparecerá una pantalla de confirmación y luego otra donde deberá decidirse dónde colocar la página web generada y los archivos anexos. Acto seguido se cerrará Excel y se abrirá dicha página en el explorador.


Rondas

Rondas

En el formulario Rondas se podrán visualizar los resultados de una jornada dada y los puntos acumulados de cada jugador en dicha jornada. Desplázate por las etiquetas de las páginas para cambiar de jornada.
Este formulario es de sólo lectura. El único sitio donde se pueden editar los datos una vez generado el torneo es en el cuadro de resultados.


Elo

Elo

El formulario Elo muestra los Elo inicial y final del jugador seleccionado, siempre y cuando haya jugado todas las partidas del torneo. En otro caso no se calculará su Elo final. El Elo final no podrá ser inferior a 1800.

Para su cálculo he usado la tabla que aparece en "1993 FIDE Handbook" para convertir la diferencia de Elo entre el Elo inicial de un jugador y el Elo promedio del torneo en porcentaje esperado de puntuación P(D). La Puntuación esperada se obtiene con la fórmula:
Puntuación esperada = [Porcentaje esperado de puntuación x (número de partidas + 1)] - 0,5
La fórmula finalmente aplicada es:
Incremento de Elo = K (Puntuación obtenida -Puntuación esperada), donde K= 15 si el Elo inicial del jugador es menor de 2200 y K=10 si es mayor de 2200.

Dado que el cálculo se complica en el caso de que no haya jugadores con Elo, la aplicación considerará que todos los jugadores a los que no se haya introducido su Elo tienen un Elo mínimo de 1800.

Pulsando el icono de la impresora se imprimirán las variaciones de ELO de TODOS los jugadores, siempre y cuando haya acabado el torneo. También será necesaria esta condición para mostrar un gráfico con las variaciones de Elo de cada jugador al pulsar el icono con las barras azules.


Jugadores

Jugadores

En esta pantalla se deberá elegir un jugador en el cuadro combinado (pulsando la flechita) y aparecerán los resultados particulares de cada jugador, junto con su elo inicial, los puntos conseguidos hasta el momento, el total de partidas jugadas y el puesto que ocupa hasta el momento. Hay que señalar que las casillas Color y Resultados en las filas de los contrincantes, se refieren al color y al resultado del jugador seleccionado, no de sus contrarios. Igualmente indicará con qué jugadores le falta por enfrentarse


Impresion

Impresión

Se podrán imprimir el cuadro de resultados, los resultados en una ronda particular, la clasificación, las variaciones de Elo y los resultados particulares por jugador. Si estamos en las hojas CuadroResultados o Clasificacion habrá que pulsar en la barra de menús. En cambio, desde los formularios Rondas, Jugadores y Elo, se pulsará el icono de la impresora en la parte superior izquierda.


Elo

Gráfico Elo

En el formulario "Elo" hay un icono representando una histograma con barras azules. Pulsándolo aparecerá el gráfico con las variaciones en el Elo de cada jugador, siempre y cuando hayan terminado el torneo. Hay que considerar que por más puntos de Elo que pierda un jugador, éste no podrá ser inferior a 1800, por lo que si ha empezado con 1800 aunque haya perdido todas las partidas, su Elo se conservará.